Performance Degradation
Incident Report for awork.com
Resolved
We will keep monitoring the performance and will provide details on what's next soon
Posted Aug 12, 2024 - 10:35 CEST
Monitoring
We have implemented a fix and are monitoring the performance
Posted Aug 12, 2024 - 10:20 CEST
Investigating
We're investigating a slower performance than usual
Posted Aug 12, 2024 - 09:49 CEST