Performance degradation
Incident Report for awork.com
Postmortem

Fixed: A small set of awork users experienced slower response times and even short downtimes over a few days. We were able to get to the root of the problem, solve it and minify the probability for this to happen again.

The issue was related to inefficient database queries that led to unexpectedly high loads on the database CPU. We took several measures to fix this for now and future times: Updated indexes for optimized query performance, refactoring SQL queries and most importantly migrating databases to a much more scalable infrastructure. This will minify timeouts in general and improve the overall performance and scalability of awork.

We are sorry for the inconvenience in any affected workspaces.

Posted Jan 30, 2024 - 12:15 CET

Resolved
Performance degradation due to unexpected load
Posted Jan 19, 2024 - 08:30 CET