Degraded performance due to high load on database

Incident Report for awork.com

Resolved

This incident has been resolved. We continue to monitor the performance.
Posted Apr 08, 2026 - 11:43 CEST

Investigating

We are currently investigating this issue.
Posted Apr 08, 2026 - 11:37 CEST
This incident affected: Web-App.