Performance Degradation
Incident Report for awork.com
Postmortem

During June 2024, we encountered several brief incidents causing awork to be slow or unavailable for some customers. Our investigation pinpointed the root cause: an inefficient, rarely used database query loading millions of rows, overloading CPU and memory on our backend services and causing interruptions.

To address this, we:

  • Reworked the problematic database query and its mischievous friends.
  • Improved the database access layer to prevent such issues in the future.
  • Enhanced our monitoring and performance across the application.

We apologize for the inconvenience and are excited to report that awork is now more robust and speedy!

Thank you for your understanding.

Best regards, The awork Team

Posted Jul 08, 2024 - 16:33 CEST

Resolved
We resolved the performance degradation
Posted Jun 10, 2024 - 10:52 CEST
Investigating
Performance Degradation
Posted Jun 10, 2024 - 09:58 CEST