awork is not loading

Incident Report for awork.com

Resolved

Database has been scaled up
Posted Dec 02, 2024 - 10:09 CET

Monitoring

awork is fully operational again
Posted Dec 02, 2024 - 09:41 CET

Investigating

We're seeing high load on our systems
Posted Dec 02, 2024 - 09:37 CET