awork partially unavailable due to infrastructure provider issues

Incident Report for awork.com

Postmortem

On October 29, 2025, awork experienced a temporary outage due to an Azure FrontDoor failure that made the app unavailable for most users. We quickly mitigated the issue by switching our edge network to an alternative solution and rerouting CDN traffic directly, restoring full functionality within two hours. We will follow up on the incident and improve awork’s resiliency to these kinds of outages.

Posted Oct 30, 2025 - 13:03 CET

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 00:39 CET

Monitoring

We have implemented a temporary workaround and awork should be available again. We will switch back as soon as the edge network is fully operational again.
Posted Oct 29, 2025 - 18:45 CET

Identified

An Azure edge networking service is unavailable. We are working on an alternative solution to get awork up and running again.
Posted Oct 29, 2025 - 18:00 CET

Update

We are continuing to investigate this issue.
Posted Oct 29, 2025 - 17:06 CET

Investigating

We are currently investigating this issue.
Posted Oct 29, 2025 - 16:51 CET
This incident affected: Web-App.