Performance degradation

Incident Report for awork.com

Resolved

This incident has been resolved.
Posted Aug 20, 2026 - 09:37 CEST

Monitoring

We have taken steps to resolve this and are monitoring the impact.
Posted Aug 20, 2026 - 09:01 CEST

Investigating

We are currently seeing degraded performance and are investigating.
Posted Aug 20, 2026 - 08:51 CEST
This incident affected: Web-App.