awork slow or unavailable

Incident Report for awork.com

Postmortem

On February 24, February 26, and March 2, customers experienced performance degradation affecting parts of awork. The impact was related to performance optimizations we had introduced earlier to improve responsiveness and scalability. While these changes showed clear improvements in our testing and controlled environments, real-world production usage exposed edge cases and load patterns that are difficult to fully replicate. At full scale, this led to slower response times for some operations.

Once the issue was identified, we rolled back the changes to restore stability. There was no data loss or security impact. We apologize for any inconvenience this may have caused and appreciate your understanding.

These incidents highlighted the gap between controlled testing and the diversity of real-world usage across our customer base. We are increasing our efforts to improve performance while keeping the system stable, strengthening our load testing, and enhancing monitoring to detect issues earlier.


Am 24. Februar, 26. Februar und 2. März haben einige unserer Kund:innen Performance-Einbußen in Teilen von awork erlebt. Diese Herausforderungen waren das Ergebnis von Performance-Optimierungen, die wir eingeführt hatten, um die Reaktionsfähigkeit und Skalierbarkeit zu verbessern. Obwohl diese Änderungen in unseren Tests und kontrollierten Umgebungen beeindruckende Verbesserungen zeigten, offenbarten reale Nutzungsszenarien Edge-Cases und Lastmuster, die schwer vollständig zu replizieren sind. Bei voller Skalierung führte dies zu langsameren Antwortzeiten bei einigen Operationen.

Sobald wir das Problem identifiziert hatten, haben wir die Änderungen zurückgenommen, um die Stabilität wiederherzustellen. Es gab keinen Datenverlust oder Sicherheitsvorfälle. Wir entschuldigen uns für etwaige Unannehmlichkeiten und danken euch herzlich für euer Verständnis und eure Geduld.

Diese Vorfälle haben uns gezeigt, wie unterschiedlich die reale Nutzung unserer Kund:innen sein kann. Wir verstärken nun unsere Bemühungen, die Performance weiter zu optimieren und das System stabil zu halten. Dazu erweitern wir unsere Lasttests und verbessern das Monitoring, um Herausforderungen frühzeitig zu erkennen.

Posted Mar 02, 2026 - 14:24 CET

Resolved

This incident has been resolved.
Posted Mar 02, 2026 - 11:31 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 02, 2026 - 10:37 CET

Update

We are continuing to work on a fix for this issue.
Posted Mar 02, 2026 - 10:18 CET

Update

We have found the cause but the implemented measures have not resulted in the expected resolution yet.
Posted Mar 02, 2026 - 10:12 CET

Update

We are continuing to work on a fix for this issue.
Posted Mar 02, 2026 - 10:11 CET

Update

We are still investigating and while we have found the root cause of the issue, the implemented measures have not resulted in the solution as expected. We are continuing to look for a permanent solution.
Posted Mar 02, 2026 - 10:09 CET

Identified

We are implementing a fix to improve the performance for all users.
Posted Mar 02, 2026 - 09:43 CET

Investigating

Some users may be experience reduced performance
Posted Mar 02, 2026 - 09:27 CET
This incident affected: Web-App and API (Core (Projects, Tasks, Time Tracking)).